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A Guided Tour of the Program

It is recommended that you follow the Introduction tutorial but you can pick and choose from
the subsequent mini tutorials. They will probably take about ten minutes each.

Introduction - loading
and viewing PDB or
mmCIF files. Essential
reading.

Surfaces - selecting and colouring
and electrostatic surfaces

Superpose proteins -
instamagic protein
superposition
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better representation
for images and packing
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Adding Text and Extra Images

Creating publication
quality images
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files
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Starting CCP4mg
Copying some data to your own area
Assigning a project directory
Loading a PDB/mmCIF file
Moving around the molecule
Finding things in the molecule
The Display Table
The Picture Wizard

Starting CCP4mg

This may depend on your installation but..

Windows: click on the ccp4mg icon in the desktop.
Linux: type ccp4mg in a terminal window.
Macs: open an X11 terminal window (to do this load the X11 application and choose Terminal from the
Application menu). Then type ccp4mg in a terminal window.

Two windows should appear: the large black 'main' window and the small white 'Display Table'. The top menu
bar in both windows is the same and either can be used.

Copying some data to your own area

Some data files are provided which you should copy to your own area. Or you can try using your own PDB or
mmCIF files and MTZ or CCP4 map files.
From the File pull-down menu select Tutorials and then Get tutorial data. You will be told that a directory
called ccp4mg_tutorial has been created in your home area.

Assigning a project directory

CCP4mg understands the project directories as used by CCP4i. It is not essential to use project directories
but they will help to organise your work. From the Project pull-down menu select Edit Projects. (If you get
any warnings about locks, choose the 'Override lock' option). A window appears which lists the known project
directories - to add a new one click on the Add project button. A new line appears with two entry fields - in
the first field enter a short one-word name for your project such as 'tutorial' and then click the browse button
and use the file selector window to select the ccp4mg_tutorial directory. To make this new 'tutorial' project the
current working project click on the menu in the Project for this session of CCP4mg line and select 'tutorial'
and then click the Apply&Exit button at the bottom of the window. You will be told that extra directories and
files are being created in the project directory - these are for CCP4i (and, in future, CCP4mg) to keep track of
your work.

Loading a PDB/mmCIF file

From the file pull-down select Read coordinate file. The file selection should list the files in your project
directory - select 1df7 or a coordinate file of your choice (preferably one containing ligands). Click on the
Select&dismiss button.
Look in the Display Table window (if you have lost it then use the Windows pull-down menu and select
Display Table). There is more about the display table soon but for now you might want to click on menu
which initially says Bonds menu and change it to something prettier such as Cylinders.

Moving around the molecule

To rotate the molecule: with the cursor in the main window, hold down the left mouse button and drag
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left-right or up-down. To rotate about the third axis hold down the shift key and the left mouse button and
move mouse in circular motion.
To translate the molecule: hold down the middle mouse button and drag.
To zoom:hold down the shift button and the middle mouse button and drag up-down.
To centre on an atom: double click on the atom

More mouse and keyboard bindings

Finding things in the molecule

From the Tools pull-down menu select Find/centre on...

A new window appears with several options at the top and then, on the line beginning 'Centre on',(going from
left to right) menus to select a molecule, a chain, and a residue. Then there is then an option to select a
monomer (that is a ligand) which is an alternative to selecting a chain and residue. And finally there is a menu
to select an atom from the residue or monomer. Alternatively you can just type in the name of the model,
chain, residue or atom that you want to find. The name is in the CCP4 atom naming format (see Interactive
selection). For example try selecting the NDP ligand from the monomer menu and then click the Find&close
button. The display should centre on the NADP ligand.

The Display Table

The display table lists all of the loaded data objects (for example each loaded PDB, mmCIF, MTZ or map file
is one data object).

For each data object the display objects are listed one per line. You probably have one (1df7) data object and
one display object currently listed. There are three columns in the table for the Atom Selection, the Colour
Scheme and the Display Style of the display object.
Try some options from the Atom Selection menu (click on the button initially labelled 'All'):

CA trace - and then choose ..and monomers and select a monomer such as //501(MTX) (or a ligand in
your model).
Residue range .. brings up a window in which you can select ranges of residues. Click on the Add
range button to add a new line then you can either select a secondary structure element such as a helix
or strand from the first menu on the left or select using the menu for the chain and residue. You can also
select a residue from the display by clicking with the left mouse button on an atom in the display and
then clicking with the middle mouse button in one of the text entry fields. Note that if you have
something like 'CA trace' or 'main chain' selected then the atoms display will be only the CA atoms or
main chain atoms of the range of residues selected.
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Select Neighbourhood of... A window will appear, the top line of the window is similar to the 'Centre
on' tool described above and allows you to select a chain, residue, ligand or atom. Try selecting the
monomer MTX and click the Apply&close button. You will see just the ligand and neighbouring
residues displayed.
Select Property... In the window that appears you can choose a property to select on (e.g. temperature
factor, solvent accessibility) and enter some limiting value - try selecting all atoms with temperature
factor greater that 20 (hint: the line looks like '20 < temperature factor').

Go back to having all atoms selected (and with and Display Style Ribbons looks nice) then try some options
from the Colour Scheme menu (click on the button initially labelled 'Atom type'):

Secondary structure
Blend thru model and in the new window just click Apply to see the default colouring of the molecule
from red to magenta from the N to C terminal.
(Switch back to Bonds or Cylinders display style). From the Colour Scheme menu choose Residue
property and Solvent accessibility to show the solvent accessibility of each residue.

To see what the colours mean you need the legend - to get this click on the icon on the left of the display
object line which looks like . This opens the display object menu,

click the option Add colour legend.

Other options on the model display object menu to try are

Hide which hides the object - click the menu again to get the option to Show the object. Note that when
the object is hidden the icon is greyed out.
Label atoms and select One atom/residue and then Label text and then click on the dashed line at the
top of the menu to 'tear-off' the menu so you can select what appears on the label. Remove the labels
by selecting Label atoms and No atoms.
List residue solvent access (only available if you have the object coloured by residue solvent
accessibility) will bring up a window listing the solvent accessibility and you can print the data to a file.

There is also a menu attached to the model object icon (currently ).
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Try the options..

Add model display object opens another line in the display table - this can be used to draw some part
of the model in a different colour or display style - beware it is initially hidden; click on the greyed icon to
make it visible.
Add display object and try Hydrogen bonds, an additional row appears in the table for the hydrogen
bond display object which atoms hydrogen bonds are drawn for and their appearance. For example, to
see only the hydrogen bonds between the ligands and the protein select ..and monomers. and All in
the left hand column (the Monomers only should be on automatically) and select All peptide in the
right-hand column.
SurfaceThe surface is not drawn immediately - you might want change the selected atoms covered by
the surface to All peptide before clicking and clicking Show from the menu.

Finally, to delete the model look at the bottom of the model icon menu ( that is the button) and select

Delete.

The Picture Wizard

And finally, the easy way to set up some standard pictures. From the Applications pull-down menu select
Picture wizard.

In the new window, from the Style folder pull-down menu select Ribbons. You can scroll though a series of
pictures and click on a Create picture button to draw your loaded model in the same style. You will usually be
presented with another window with options to select chains or residue ranges to be drawn in the new style;
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leaving these blank usually defaults to drawing the whole molecule in the new style.

Only beware, if you have more than one model loaded, that you select which model that you want redrawn.
Click the Create picture button in this window to draw the picture.

The ribbon picture wizard styles will create one or more display objects for the protein drawn in ribbon style
and then additional, separate display objects for any disulphide bonds, nucleic acid, ligands, metals or solvent
that are present in the coordinate file.

Note also that at the top of the file browser (File menu, Read coordinate file there is a menu to choose
Representation style which list the Picture Wizard style which can be applied to the model on loading.
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Notes

Creating and colouring a surface

Load a small protein such as 1df7 (small so calculations are quick). There are two ways to
create a surface:

In the Display Style menu of a model display object select Surface
Click on the model icon (a dot next to the model name) and from the menu select Add
display object and Surface to create a surface display object. This approach gives you
more options.

Calculating a surface may take a little time so when you create a surface display object it is not
drawn immediately - you have the chance to select the atoms to be covered by the surface and
then you should click on the surface display object icon and select show.

Most of the items on the surface Colour Scheme menu are the same as those on the model
colour scheme menu - the surface will just be coloured the same as the underlying atom. The
extra option at the top of the menu are to colour by electrostatic potential (try it).

Covering a limited set of atoms

For example to create a transparent surface over just the binding site for the MTX ligand
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First use the surface display object menu Hide the surface while we make two changes. Then
select Neighbourhood of from the surface Atom Selection menu and in the top line of the
window select the monomer //501(MTX). Note that the selection radius is set quite high to 7A
and that, by default, solvent and the named central atoms (that is the MTX ligand) are excluded
from the selection. Hit the OK button. If you draw the surface now it will completely wrap
around all of the selected atoms as if they were a single separate molecule. To prevent this go
to the menu in the Display Style column to select the context for the surface and select All
peptide. Now click on the surface display icon and select Show.

Click on the surface display object icon and select Surface drawing style. Try the various
options. The opacity of the transparent surface can be changed by selecting Set transparency
from the View menu, settting the opacity to say 0.5 for your surface object and then clicking the
Transparency on/off.. to on. The transparent surface is very slow to rotate so it is better to
either hide the transparent surface or switch back to opaque surface if you need to rotate the
model.

To get the image in the picture you need to set up ..
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Notes

The calculation parameters and colour scheme for surfaces can be set in the Preferences
window (find this at the bottom of the Tools menu).
More information on surfaces here.
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Load homologous proteins
Superpose
Multiple homologous chains
Non-homologous proteins
See general Superpose documentation

Load homologous proteins

Select two homologous proteins such as 1df7 and 8dfr (hint to remove existing models: from
the Tools menu select For all data and Delete).

To set the colour and display style for all models: from the Tools menu select For all models
and Appearance.. and in the new window set Colour to By molecule and Display style to
Worms and then Dismiss this window.

Superpose

From the Applications pull-down menu select Superpose.

In the new window check that the Superpose mode (at the top of the window) is Secondary
structure(SSM) and hit the Superpose button. The models will be superposed. To show the
equivalent residues and distances between CA atoms toggle on the button labelled Show
matched residues...

Multiple homologous chains
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You can also try superposing the 4dfr structure which contains two equivalent chains - if you
want to treat these as two separate models load two copies of 4dfr and in the Atom selection
column for the first copy select ..of chains and select chain A. Similarly select chain B for the
second copy of 4dfr. The Superpose proteins window should now list the two 4dfr models - for
each of them click the button labelled 'All atoms' and select As display object and select the
name of the chain. Now click the Superpose button.

Non-homologous proteins

This application will also make a good job of superposing non-homologous structures - it will
overlay any similar pattern of secondary structure elements that can be found and the possible
alternative matches can be reviewed.
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Introduction

Load any molecule of interest to you or use any one from the tutorial. It is easiest to work if the
Display style is Bonds or Fat bonds.If you want to look at two or more homologous structures
then the structures can be superposed - see the Protein Superposition tutorial. If you are
looking at a new structure then some of the following selection and colouring tools may help
you to familiarise

Colour by By chain or Blend thru model and display style Ribbons to see the overall
fold of the protein.
Add another model object (to do this click on the dot menu and select Add model
display object) and from the Atom selection menu select ..and monomers (only present
if there are ligands in the structure) and select All monomers. Change the Display style of
these to something distinctive such as Cylinders or Ball and stick.
If the structure contains multiple NMR models, nucleic acid or alternate conformations
then options to select these features will be on the Atom selection menu.

Geometry

This section introduces some basic tools for interrogating the structure. From the Application
menu select Geometry. A panel appears on the right side of the display window with a section
titled 'Geometry'.
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Try clicking on the Distances option and then, with the left mouse button click on pairs of
atoms in the structure to show their inter-atomic distance. Note that the Distances button is
highlighted in gold to show it is the active tool and the cursor is a cross to indicate that any
atom picks will be used by the active tool. Now try clicking on the Distances/angles tool. A
new window appears that will list the distances and angles between picked atoms. Pick a
series of atoms and look at the information in the window.

Try clicking on an atom with the right mouse button and select the option Contacts around
this.. and residue which will show close contacts around the selected residue (note that there
might not be any close contacts). The cutoff distances for close contacts can be changed in the
Geometry applications Preferences window which can be accessed by clicking, with the
RIGHT mouse button on the Geometry title and selecting Preferences from the menu.

The contacts and distances can be cleared from the display by clicking the Clear contacts
button. Individual contacts can be deleted by clicking on the contact dashed line with the right
mouse button and selecting Delete contact.

If you want to include the contacts in an output image you may want to have more options on
display style. This is possible if you export the contacts as vectors using the Export vector
button - see Displaying vectors

Hydrogen Bonds

To display the hydrogen bonds within the loaded model click on the dot icon next to the model
name and from the menu select the Add display object.. option and from the sub-menu select
Hydrogen bonds. Note also the Close contacts option on the same menu that has a very
similar interface to the hydrogen bond interface that we are about to look at. Now all hydrogen
bonds within the structure are displayed and, in the display table, an extra line appears under
the model name. This line has an icon , if you click on this one of the menu options is

Label - select this and the sub-menu option Label bond lengths. From the same menu you
can also select List/Save to file and a new window will appear listing all of the hydrogen
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bonds.

Several tools create similar windows; for example listing close contacts, secondary structure
and the solvent accessibility. A couple of features of these windows are worth noting. Firstly,
you can click on the Save to file option at the bottom of the window to save the listing to a file.
Secondly if you click on an atom name (with the left mouse button) then that atom will be
labelled in the main display window and if you double click on an atom name then the view will
change to zoom in on that atom.

It is possible to display only the hydrogen bonds between two specified sets of atoms. The two
sets of atoms are controlled by the menus in the Atom selection and Display style columns of
the table. By default the atom selection is 'All'; click on this and change it to Main chain. The
second set of atoms remains 'Same as selection' so only HBonds between main chain atoms
are shown. Now try changing the 'Same as selection' to Side chains to see all HBonds
between main chain and side chain atoms.

The criteria for HBonds can be changed in the Preferences window (on the Tools pull-down
menu) - look in the Model analysis folder for Hydrogen bonds. The algorithm and parameters
are explained in the Structure Analysis documentation.

If you want to include hydrogen bonds when creating an image you may want to have more
options on display style or to be able to add or delete some bonds. These things are possible if
you export the hydrogen bonds as vectors - see Displaying vectors.

Solvent Accessibility Surface

The solvent accessible surface area is the surface area that is accessible to a 'water molecule'.
In calculations the 'water molecule' is usually represented by a sphere of about 1.4Å radius
(see Analysis documentation). To colour a model by the SAS area: from the Colour scheme
menu select Residue property and then Solvent accessibility. There may be a short pause
for the calculation and then the model is coloured with mostly blue on the inside of the model
and red residues on the outside of the model. To see a colour legend click on the display
object icon menu and select Add colour legend. A legend appears at the bottom of the

screen and an extra line also appears in the display table; it represents the legend object that
can be manipulated in the same ways as any other legend object (for example click on the dot
menu and select Delete).

Another option on the display object icon menu is List Residue solvent access. This

will open another window listing the solvent accessibility of residues and atoms. The data can
be saved by clicking the Save to File button. Also try double clicking, with the left mouse
button, on any atom or residue name; the display will recentre on the atom or residue.

The parameters for the SAS calculation can be changed in the Preferences window (on the
Tools menu); open the Model analysis folder and select Solvent accessible surface. There
is little reason to change these but you may want to change the colour coding. To do this open
the Model colours folder in the Preferences window and select Residue solvent access.
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The window has a table showing the parameter value and the colour for that parameter value.
Every residue on the display is given a colour, dependent on its SAS, which is interpolated
from the fixed values and colours in the table. If a residue SAS falls outside the normal range
of values in the table then it is given one of the colours, specified at the top and bottom of the
window, for below or above the normal range. The 'outside normal range' colours are usually
contrasting the normal colours in order to draw attention to outliers but they could be made the
same as the normal range colours. Note that any solvent in your model is coloured green (or
the below normal range colour) because it is usually excluded from the SAS calculation and
assigned a value of -1.0.

Note that there is also an option to colour by atom SAS: from the Colour scheme menu select
Atom property and then Solvent accessibility.

Displaying vectors

Generate a vector file by either

In the Geometry application, when you have some contacts displayed, click the Export
vectors button
Click on the Hbond display object icon and select Export vectors

In the file selection window enter the name for a vector file and make sure that the Load
vector file button (at the top of the window) is clicked on. When you click the OK button the
display window should not change significantly but a new vector object should be listed in the
display window. The contacts or HBonds have been written to a file and then that file has been
loaded and displayed in a similar style to the original data. To avoid confusion with the original
data either

Close the Geometry application by clicking with the right mouse button on the Geometry
title and selecting Remove from the menu
Click on the HBonds icon menu and select Delete from the menu

Now look at the new vector object in the display table and click on the middle column, labelled
Line style/colour (the button is probably labelled 'red dashed' or 'white dashed') and try various
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options from the menu changing the line style and line colour. For example style dashed
cylinder works well if your model is displayed as cylinders or ball and stick. You may want to
change the cylinder radius and dash length.

Also try changing options on the Label style/colour menu.

After you have changed the appearance of the vectors it is advisable to save the changes to
the vector file. (Note that, unlike say model coordinate files and map files the vector file can
contain information on how you would like the data to be displayed). To save the file click on
the dot and select List/save to file from the menu. A new window will appear listing the
vectors and their appearance (the format is explained in the Vector documentation). Click on
the Save to File button at the bottom of the window to save this listing.
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Picture Wizard
More complex selection tools using the selection language are described in the Selection
language tutorial.

Introduction

Making pictures can take a lot of time and much of that time is in selecting what to include in
the picture and choosing the colouring - using the programs selection tools effectively can help
save a lot of that time. The representation of a model is built up from several model display
objects. All of the atoms in one display object must obey the same colouring scheme rules and
will have the same display style (e.g. 'ribbons' or 'cylinders'). This tutorial is complementary to
the Colouring tutorial. The quickest way to set up a complex picture is using the Picture
Wizard, which creates the display objects for you but this tutorial explains the background for
customising the Picture wizard pictures.

Simple menu-based selection

Load dUTPase (with the Representation style in the coordinate file selection window set to All
atoms) and try to create a picture of the ligand binding site of one of the three homologous
ligands. Create additional model objects by clicking on the model icon, the dot by the model
name, and selecting Add model display object. Set up three model display objects; one for
the monomer //D/1(DUX) and the other two containing the B and C chains. You can choose
how to display and colour these objects but for example the setup
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gives the image

The ligand D/1(DUX) is selected for the first object by using the ..and monomers.. selection
menu item and selecting the D/1(DUX) from the submenu. The A and C chains are selected
using the ..of chains.. selection menu item and selecting the appropriate chain from the
submenu. Also shown here are the hydrogen bonds between the ligand and the protein by
selecting Add display object and Hydrogen bonds from the model icon menu and then
limiting the display to hydrogen bonds between two sets of atoms. The first set is selected in
the first column of the hydrogen bond display object - choose the monomer //D/1(DUX) and the
second set, selected in the third column, is All peptide.

Copying selection to another model

Load the model 1snf which is a homolog of dUTPase. From the model icon menu (the dot next
to the model name) select Display same as and dUTPase. The current display setup for
dUTPase will be copied to 1snf. The 1snf has different ligands and so the display object
selections which require the name of the ligand need to be entered again: for the first display
object and the hydrogen bonds object select ..and monomers and //1170(UMP)

In future we do intend to make the 'Copy from' tool smarter so it will recognise equivalent
ligands and residues. You can delete or hide the 1snf model; it will not be used again.

'Neighbourhood' to select active site residues

Create another model object for dUTPase and, from the Selection menu, pick Neighbourhood
of. A new window appears. In the top line of this window you select the 'central' atoms whose
neighbours will be found. From the or monomers menu select D/1(DUX). By default the
selection group (fourth line of window) should be residues - change this to main/side chain so
that if a side chain atom is close to the ligand all of the side chain is selected and if a main
chain atom is close then all of the main chain of that residue is selected. Set Radius to 4.0 (Å).
Click Apply. Make the display object visible and display style Cylinders. The side chains of
the active site are displayed.

For your picture you may choose to add or remove some side chains or main chain atoms - the
interactive selection tools, described in the next section, could be applied with the
'neighbourhood' selection as a starting point. But in the example below it is not used so make
this display object invisible to avoid confusion.
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Interactive selection

To manually choose the residues of the active site create another model display object, make it
visible and initialise the selection to no atoms by clicking No atoms on the selection menu.
Then, from the bottom of the selection menu, pick Interactive selection and Simple. A new,
temporary, object appears on the display which is a thin bonds display of all atoms in the
model and you can click on items in this display to select them for permanent display. It is
probably easier if you Hide the two ribbon objects for now. If you look around the ligand you
will see hydrogen bonds to the main chain atoms of residues C/115 to C/117. To select this
section of chain for display click on one atom in each residue with the RIGHT mouse button
and from the popup menu pick Select this.. and main chain. The selected atoms will be
displayed with fat bonds. Other residues whose side chains might be selected are C/113(ASN)
which forms a hydrogen bond to the ligand and C/112(TYR) and C/46(PHE) whose aromatic
rings stack against the ligand. When happy with the selection go to Interactive selection
again and switch off. The temporary thin bond object will disappear and the newly selected
residues can be changed to a nicer display style such are Cylinders. The ribbons can be
switched back on. A couple of final refinements..
the colour of the side chains can be set to the same colour as the C chain ribbon but check the
option Non-carbon by atom type on the colour menu
the hydrogen bonds can be fatter - from the hydrogen bond icon menu select Line width

and set to 4.

A final image might look like this.
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Picture Wizard

To create a similar scene automatically open the Picture wizard from the Applications
pull-down menu. From the Style folder menu on the Picture wizard menu bar select ligand
binding site. A series of ligand binding site scenes are shown; try the site_and_ribbons
picture style by clicking on the Create picture button for that scene. A new window appears:
make sure that the selected model is pUTPase and for the first ligand select D/1(DUX) then
click the Create picture button. The scene in the display window will be redrawn; click the
Notes button for the site_and_ribbons picture style to get an explanation of the picture.
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Introduction

Making pictures can take a lot of time and much of that time is in selecting what to include in the
picture - using the programs selection tools effectively can help save a lot of that time. The
representation of a model can be built up from multiple model display objects. All of the atoms in one
display object must obey the same colouring scheme rules and will have the same display style (e.g.
'ribbons' or 'cylinders'). This tutorial is complementary to the Selection tutorial.

Load a model (for example try dUTPase from the tutorial data). It will look nice drawn as Ribbons. The
model is a trimer with three bound ligands. Add another model object (click on the model icon, the dot
by the model name, and select Add model display object) and for this object click on the Atom
selection and select ..and monomers.. and select All to select all of the ligands. Click on the model
display object icon and select Show and also set the display style to Spheres.

Changing the 'standard' colour schemes

The DUX ligand contains an atom of fluorine which is currently coloured white in the 'Atom type'
colouring scheme. This could be changed by opening the Preferences window (from bottom of the
Tools pull down menu) and selecting Atom type from the Model colours folder. To add a colour for
fluorine click on the Add range/colour button and enter ' F' in the type column and choose a colour (I
have used cyan). Close this window.

The Model colours preferences change the standard colour schemes which are on the Colour
scheme menu for all models. The next section shows how to set up a novel colouring scheme.

Creating a customised colouring scheme

Models are loaded with the default colour scheme 'Atom type' - try changing this to Secondary
Structure and then pick Edit colour scheme... In the new window you can customise the colour
scheme stating from the default colouring by secondary structure. For example you might want to set
the Beta bulge which are currently green to the same colour as the beta strands and you may decide
to not colour the different turns - these lines can be removed from the table by clicking with the right
mouse button on either of the menubuttons in the line and selecting Delete selection/colour. Note
that many tables in the interface have the same functionality on a 'right mouse menu'. You can also
change the colours of course. Then to save your colour scheme enter a one word name in the
Scheme name line and click on the Save now button. By default this colour scheme will only be
available for the dUTPase model; the information is saved in a file called dUTPase.ccp4mg and is
reloaded next time you load the same model. If you want the colour scheme to be available for all
models then click on the menu labelled Save the colour scheme for and change to all models. If you
now Close this window and change the colour scheme to something else you can later restore the
saved scheme using the Restore colour scheme option.
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To create the image above with the loop regions coloured differently for each of the three chains you
need to to put the rules for colouring the chains (e.g. 'chain A is coloured yellow') before the rules for
colouring the helices and strands so in the Edit colour scheme.. interface click on the line labelled
'beta strand' and use the 'right mouse menu' option to Insert above and create two new rows. Then
click in turn on the buttons currently labelled 'No structure' and 'All atoms' and choose ..of chain.. and
select chains A, B and C for the three rules and then select a colour for each of them. So the window
looks like this
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While the Edit colour scheme window try clicking on an atom with the right mouse button depressed.
The menu which appears has options to reset the colour for the picked atom, residue or secondary
structure element. Also try selecting the option Residue range from and then right-mouse click on
another residue and select the Residue range from your first residue and select a new colour. The
range of residues will be recoloured and a new line will appear at the bottom of the Edit colour scheme
window showing the new colour rule for the range of residues; you can click on the selection button,
which is labelled Ranges etc. and pick one of the options Main chain, Side chain or CA trace to limit
the selection to these residues within the range.

If you want to change the defined colours or define new colours then either:

Select Interactive from the bottom of one of the colour menus in the Edit colour scheme window
Open the Preferences window (from the bottom of the Tools menu) and select Colours from
the Display folder.

In the colour browser window choose the colour to change from the menu labelled Define colour at
the top of the window or select Add new colour from the bottom of the menu and enter a name for
the colour and hit the Apply button. To change the colour you can

Use the sliders to set red/green/blue or hue/saturation/value
Move the small square around the colour circle
Click on the Pick colour from screen button and then click on a point on the screen

Colouring Hints

If defining the colouring rules seems to be getting complicated it may be easier to split the
displayed atoms between two or more display objects.
Beware that pretty pastel shades are often washed out when projected and that the best
contrasting colours can depend on the background colour.
If you are making a series of images for a presentation or paper then try to be consistent in the
colouring through all of the images.
A colour legend may be helpful to an audience. See the tutorial on Legends and Annotation.
In similar vein, also try to be consistent in the choice of views, and show or explain the
relationship between views. Use the Save/restore views option from the Tools menu.
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Download from structure database at EBI or RCSB

You need to be connected to the Internet. From the File menu select Download coordinate
file and in the download window enter the 4-letter code for a model (e.g 1alz). If you click
return in the code window then a default name for the local PDB file is shown in the line below.
Click the Apply button and the file will be downloaded to your computer and read into
CCP4mg.

If you do not know the 4-letter code for the structure that you want then click on the View
server web page button to bring up a web browser showing the structure database query
page. Once you have found the structure you want you can use either the database download
option or the CCP4 interface. If you have difficulty reading a file from a database then check
that it is not a PDB file wrapped in an HTML file.

Thermal Ellipse

Load the model 1alz.pdb or use any other coordinate file. Click on the model icon menu (the
dot next to the model name) and select Add display object.. and Temp factor spheroid. If
the ellipse are not immediately displayed then click on the display object menu ( ) and

select Show. By default the thermal ellipse are displayed as axes but they can be changed to
solid using the menu in the right-hand, 'Display style', column.
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(Mis)Using the PDB File Temperature Factor Column

It is common practise for programs to output a variety of data to the temperature factor column
of a PDB file - that is characters 61 to 66 of the lines beginning with the word 'ATOM'. CCP4mg
will read such a PDB file and can display the data by various means. Load the PDB file
1df7_consurf.pdb which contains the output from the ConSurf server for 1df7.pdb with the
conservation of residues listed in the temperature factor column. The file pdb1df7.aln shows
the sequence alignment for 50 homologous dihydrofolate reductase structures and the consurf
value in the PDB file indicates the degree of conservation for each residue in structure. The
lower the consurf value the more strongly conserved the residue. Listed below are some ways
of viewing that data.

Since the non-peptide atoms do not have a consurf value and, in fact, still have the 'correct'
temparature factor which might be confusing, exclude them from the display by changing Atom
selection to All peptide.

List the PDB File

From the model data object icon menu (the dot next to the file name) select List data and All
atoms. A window listing the PDB file appears. Scroll down to the lines which begin with the
word 'ATOM'. Note that the 'temperature factor' values are the same for all atoms in one
residue. To look at a particular residue in the file: double click (with the left mouse button) on
one line in the file - in the main graphics window the display will focus on the atom that you
have just clicked. Click on the Close button to close the listing window.

Labelling the atoms with the data values.

Click on the model display object icon menu and select Label atoms and One

atom/residue to label just the CA atoms (all the atoms in one residue have the same value).
Then click on Label text from the model display object icon menu and click the dashed line at
the top of the sub-menu to 'tear-off' the sub-menu into a separate window. Then click off the
labelling of Chain and Residue (or whatever is currently on) and click on the labelling of
Temperature factor. To switch off the labels: go back to the Label atoms menu and select No
atoms.
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Colouring by 'Temperature Factor'

From the Colour Scheme menu select Atom properties and Temperature factor. The model
will probably be redrawn in green and blue in a way that is not very helpful because the values
of the consurf parameter are not in the same ranges as usual temperature factors. The
colouring scheme for the 'temperature factor' can be changed in the Preferences window
(bottom of the Tools menu). Look in the Model colours folder for Temperature factor.
Change the Data values for the colour ranges to be:
blue : -1.5
white : 0.0
red : 6.0
Also change the Interpolate mode to between RGB values - see colour interpolation. The
peptide atoms will be coloured by blue to white to red depending on their consurf value of their
residue. Non-peptide atoms are coloured yellow. If the model is drawn in display style Ribbons
then it looks like this:

Selecting residues with a range of data values
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Restore the display style to Bonds. To select only those residues with 'temperature factors' in
a given range of values select Property from the Atom Selection menu. The selection criteria
is, by default, Temperature factor so you can just enter upper and lower range values in the
two text boxes - for example enter '-1.5' in the lower range value and '0.0' in the upper range
value and then click Apply to display only the conserved residues.

Colouring residues with a range of data values

In the previous example of colouring by 'Temperature Factor' the colours are blended between
blue and white or between white and red. In this example the residues are grouped into ranges
of data values and all residues within a given range are given the same colour.

Revert Atom selection to All peptide. From the Colour scheme menu select Edit colour
scheme... In the new window click on the Add selection/colour line a couple of times so that
you have two lines in the window in which you can select two sets of residues and give them a
colour. Click on the Atom selection button in the first row (labelled 'No atoms') and select
Property from the menu and in the new window enter -1.5 and 0.0 to select atoms with
'Temperature factor' (i.e. consurf values) in this range. Click on Apply and Close. Back in the
Edit colour scheme window select a colour for these first set of atoms. Now select a second set
of atoms with 'Temperature factor' values in the range 0.0 to 6.0 and give them a different
colour. This has created only two groups - obviously you could create more. You can enter a
name and save the colour scheme.

Displaying the peptide as spheres and adding another model object to display the inhibitor and
cofactor as cylinders gives the following picture which shows the conserved residues, in
magenta, around the ligand binding sites.
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Loading a map and model

Load the coordinate file toxd.pdb and then read in either:

A CCP4 map file: from the File pull-down menu select Read map or MTZ file and then
CCP4 map file and select toxd_sfall1.map.
A CCP4 MTZ (structure factor) file: from the File pull-down menu select Read map or
MTZ file and then CCP4 MTZ file and select toxd_sfall1.mtz. In the new window you can
select the structure factor and phase data from the file - accept the defaults by clicking
OK.

The display table will then look like this:

There are rows for the loaded coordinate and map data and also a row for a Crystal. The
display style is 'Continuous crystal' by default; to understand this try holding down the middle
mouse button and dragging around the screen - the map will update automatically to cover the
area at the centre of the screen and symmetry related models will appear when necessary. (If
the symmetry models do not appear then look at the menu labelled Models in crystal and
make sure that the toxd is set 'on').
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For the map display object the Contour level has a slider which can be used to changed the
contouring level. The scale is in an absolute scale of electrons/A3 but this can be changed to
sigma levels (and other defaults can be changed) in Map options on the Preferences window
(access this from the Tools pull-down menu).

Better map representation for making images

The map display style can be changed by clicking the display object icon , selecting

Surface style.. and then selecting an alternative to the conventional default chicken-wire style.
Cylinders style is useful for creating distinct electron density maps for making images.

The appearance of the map can also be improved by reducing the map grid size. If you loaded
data from a map file then the grid size is fixed in the file but if you loaded data from an MTZ file
then try clicking on the map icon (currently a dot) and then select Map grid size from the
menu. Try resetting the grid size to 0.5 - there will be a short delay whilst the map is
recalculated.

Another way to simplify an image is to show just the map around the features of interest and
clip out extraneous density. To demonstrate this first create an new display object for the toxd
model (click on the dot icon and select Add model display object) and then select a small
number of residues for this object, for example by using the ..of residue ranges.. option and
selecting a short range of residues. Displaying these residues in Cylinders style will improve
the picture. You may need to find these residues on the display by choosing Centre on from
the display object icon menu .

Now to display just the density around these residues click on the map Extent menu and select
Clip.. and to toxd Ranges...
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Packing diagrams

To show the packing of the molecule in the crystal first hide the map by selecting Hide from the
map display icon menu and then change the Crystal Display style from 'Continuous crystal' to
Contents of one unit cell. All the symmetry models necessary to fill a unit cell will be
displayed. The Cell edges can also be toggled on from the Crystal Display style menu. The
image may be clearer if you change the atom selection for the toxd model to CA trace.
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Entering Text

There are currently two types of text ..

A 2D legend that can be placed anywhere on the screen and that will not move if the view
is changed. To create a legend select Add legend from the file pull-down menu.
3D annotation on a model that will move with the model. To create annotation you must
have a model loaded then from the model data menu select Add display object and
then from the sub-menu Annotation.

The legend and annotation objects have many features in common - try these..
Click on the button labelled Enter text.. to open a window with a simple text editor. Type in
some text. Note that you can customise the text using the Underline, Bold, Italic buttons or
Colour menu. Click the Apply button to display the text in the main graphics window. By
default a legend is first positioned at the bottom left of the screen. Annotation text is by default
placed at position 0.0,0.0,0.0. If you can not immediately find the annotation click on the icon

and select Centre on from the menu; this should change the view to centre on the text.

From the legend or annotation icon menu (click on ) select Font and try changing the

font.

Probably the easiest way to add annotation to the display is using the tools in the Picture
Wizard.

Moving Text

From the icon menu try selecting Move object. The icon is highlighted in gold to indicate that
this is the active moving object. To move the text hold down the Control key and the middle
mouse button and drag the text.
An alternative way to move a legend is using the sliders on the display table that control the x
and y coordinate of the bottom left of the text. The extent of the screen is between zero and
one with x=0.0,y=0.0 being at the bottom left of the screen.
An easier way to place annotation on a particular atom or residue is using the window opened
by clicking on the button in the right hand column of the display table. In this window is the
usual atom selection tool with menus to select a chain, residue, monomer and atom. Note that
you could also 'cut-and-paste' an atom into the final entry box by clicking on the atom with the
left mouse button and then clicking in the entry box with the middle mouse button. You must
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then click the Apply button to move the text to the selected atom. If you select a residue or
monomer then the text will be placed at the centre of that entity. While this window is open
there is also the option to drag the text with the Control key and middle mouse button.
Remember to rotate the view 90 degrees about the y (vertical) axis to look at the image 'from
the side' to check the placement of the annotation in the third dimension.

Adding Other Images

CCP4mg can load and display images in PNG,GIF and JPG format. The image can be scaled
and moved around the screen. This option might be useful for displaying a logo or, say, a
graph.
From the File pull-down menu select Add image and select the file weblogo175.gif. The CCP4
logo will appear at the bottom left of the display window. The image is represented on the
display table by a line containing three slider bars. The one on the left controls the image scale
and the other two control its position. The image can also be moved by clicking on the

icon and selecting Move object. Moving the image is then the same as for moving text as
described above. Note that this image has a transparent background and this is probably a
desirable feature for many images that you might want to display.
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Note: If you have a packing diagram set up after the Maps tutorial then this is a good example to output in PostScript format so go here first.

Things to consider before making a picture

Once you have set up the picture on the screen things you might want to check:

The appearance of ribbons, cylinders etc. can be changed in the Preferences window (accessed from the Tools menu); click on the Model display folder
and choose Drawing style. If necessary you can set these drawing style parameters for individual graphical objects - from the model display object icon
menu select Molecule drawing style... Note that graphical primitives such as ribbons and spheres can be drawn at variable speed/quality (in Preferences,
Display folder, Render quality) but when outputting an image the program automatically changes these to best quality.
Is the background colour appropriate? Look at the View menu Background colour.
Is the fog level appropriate? The depth queue fog can be toggled on or off from the View menu Depth queue fog or the fog level changed using the Clip
plane/depth que slider option on the View menu to open a panel, at the bottom of the main window, with a slider controlling fog density.
Usually the output image will have the same pixel resolution as the display window so choose an appropriate window size and ratio. Note that images to be
put into printed publications need to be saved at much higher resolution such as 1000x1000 pixels which implies a bigger image. To get high resolution
images it is recommended to save at 2 or 3 times the screen size (see later notes).
When outputting an image file the program automatically saves the program status to a file with the image file name and the extension .pkl. If the image
needs changing later the status file can be loaded via the Save/restore option on the Tools pull-down menu. A good reason for annotating images within
CCP4mg rather than adding labels afterwards is that the annotation is saved and will not need redoing if the image is revised.
In the Preferences Images and movies folder look at the Screenshots options. When creating an image file the program can take the picture directly from
the screen or it can redraw the scene in an offscreen buffer and output the image from there. The disadvantage of taking the picture directly from the screen
is that if any part of the display window is covered then what should appear there is lost from the output image. It is better therefore to use the back buffer but
this may not work on all hardware. Another improovement is to smoothe the edges of ribbons and spheres etc. by anti-aliasing. This process takes a few
seconds but produces a much neater result. Unfortunately this also may not work on all hardware. Ideally in the Screenshots options you should set the
offscreen buffer and anti-aliasing on.

Screen snapshot

Set up any picture - if you have nothing already try loading rnase.pdb and choosing one of the ribbons representation styles from the top of the file browser
window.

A screen snapshot can be output in a variety of formats; from the File menu select Output screen image.. and Screen snapshot and select the required output
file type from the menu in the file browser. Look at the options at the top of the file browser window - these can be used to set the resolution of the output image.
Enter a file name and hit the OK button. There may be a short pause while the image is written out and then a web browser window should appear displaying the
new image.

Now try again but in the file selection window click the button by Display window size with magnification to set magnification on and set the magnification to 2.

Also try creating a stereo image. Switch the screen magnification back to 1 and toggle on the Make stereo picture button and hit the OK button. This time three
files will be created: filename_left.ext and filename_right.ext which contain the left and right eye view and filename.ext which contains a merged left and right eye
picture.

PDF Creator - PDF4Free v2.0                                                    http://www.pdf4free.com

http://www.pdfpdf.com/0.htm


CCP4 Molecular Graphics - Presentation graphics file:///E:/ccp4mg-rel-1-1-linux/help/tutorial/images.html

2 of 2 13/11/2007 16:00

Output Postscript

Postscript output works best for pictures which contain only lines such as models drawn in Bonds display style and maps in chicken-wire style but will reproduce
these at very high resolution. Try setting up such a picture and output select Output screen image.. and Postscript snapshot. The picture below is not actual
Postscript because is will not work in web pages but the picture shows the sort of diagrams that are presented well by Postscript.

Reviewing Images

By default a newly created image will be displayed in your web browser. You can prevent this by setting the Display image in web browser option off the
Preferences window (on the Tools pull-down menu, in the Images and movies folder.)

The following suggestions depend heavily on the setup of you computer.
To see the images that you have created try using the operating system file browser to select the image file which should be in the directory ccp4mg_tutorial which
is in your home area. Under Windows this probably means C:\Documents and Settings\your_name\ccp4mg_tutorial. The browser should choose an appropriate
program to display the file but note that a Windows system might not have anything appropriate installed to view a PostScrpit file.
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Download from structure database at EBI or RCSB

You need to be connected to the Internet. From the File menu select Download coordinate
file and in the download window enter the 4-letter code for a model (e.g 1alz). If you click
return in the code window then a default name for the local PDB file is shown in the line below.
Click the Apply button and the file will be downloaded to your computer and read into
CCP4mg.

If you do not know the 4-letter code for the structure that you want then click on the View
server web page button to bring up a web browser showing the structure database query
page. Once you have found the structure you want you can use either the database download
option or the CCP4 interface. If you have difficulty reading a file from a database then check
that it is not a PDB file wrapped in an HTML file.

Thermal Ellipse

Load the model 1alz.pdb or use any other coordinate file. Click on the model icon menu (the
dot next to the model name) and select Add display object.. and Temp factor spheroid. If
the ellipse are not immediately displayed then click on the display object menu ( ) and

select Show. By default the thermal ellipse are displayed as axes but they can be changed to
solid using the menu in the right-hand, 'Display style', column.
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See also Animation reference.

Introduction

This is an example of a morph which is a short animation that shows the transformation
between two conformations; it is intended to help a viewer visualise the differences between
the conformations and there is no claim that the intermediate steps represent a true
conformational pathway. The tutorial directory contains a subdirectory morph which contains a
series of PDB files which come from the morph server MOLMOV (Yale Database of
Macromolecular Movements) and show a morph between two conformations of the NMR
structure 1liz.pdb.

See an example here - morphing between two of the NMR models in 1liz.pdb done by
MOVMOL.

Viewing an Animation

Delete any loaded models (from the Tools menu select For all models.. and Delete) and then
load the PDB file ccp4mg_turial/morph/ff0.pdb which is the first file of the morph. From the
model icon menu (the dot next to the model name 'ff0') select Animation and Select multiple
PDB files.. and again select the PDB file ccp4mg_tutorial/morph/ff0.pdb - the program will now
automatically select all of the other PDB files in the morph directory with related names. Now
go again to the model icon menu and select Animation and Run animation to see the
animation. It can be stopped by clicking the Stop animation button at the top of the graphics
window or by hitting the keyboard escape key.

Now try creating a more complex picture - for example making the display style for the model
Ball and stick and by displaying hydrogen bonds (from the model icon menu select Add
display object.. and Hydrogen bonds). And run the animation again.

Making a movie

There is a separate Movie tutorial and movie reference with more information but this section
will show quickly how to record an animation. If you are making your first movie then from the
Applications menu choose Movies and New movie and enter a name; a directory,
project_directory/movie_name.ccp4mg_presentation will be created this is where images are
stored and the movie will be put.

Now reset the conformation to the first step by selecting Animation and Go to step.. and in
the new window setting the step to zero. Make sure the model is suitably positioned in the
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centre of the screen.

Now make a snapshot of the current display by right-mouse clicking on the frame in the movie
window labelled Insert next snapshot here and select Insert current view/display from the
pop-up menu. A small image of the current display should appear in the movie window. This
snapshot is labelled 00001 (any subsequent snapshots will be labelled 00002, 00003 etc.). A
movie scene will be created based on this snapshot; beneath the snapshot are the options for
the scene. The time for the scene to run should be set automatically to accommodate one run
through the animation. On the bottom line of this interface change the Display to interpolate.
From the Action menu choose Preview; this should show, in the main graphics window, what
will appear in the movie but will not actually record anything. It should run once through the
animation. If you double the run time and Preview again you should see the animation run
forwards and then backwards to finish on the initial frame. To actually make the movie you
should select Record from the Action menu - this will save the screenshots that will make the
frames of the movie. When this is finished select Compile scene(s) from the Action menu; this
runs an external process to convert the individual frames into one movie file, when the process
is finished the movie should be played automatically. The movie file will be called something
like

...ccp4mg_tutorial/test.ccp4mg_presentation/scene_00001/movie.gif
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